PHP7.2/7.3への対応

SQLのエクスポートをしようとするとこの様なエラーが出るように…
php7.2/7.3になって文法がいろいろ変わったせいだと思われる。
該当箇所を修正するとエラーが無くなりました。

count()関係の変更
Warning in ./libraries/plugin_interface.lib.php#532
count(): Parameter must be an array or an object that implements Countable

- if($options!= null && count($options)> 0){
+ if($options!= null && count((array)$options)> 0){

/usr/share/phpmyadmin/libraries/plugin_interface.lib.php


カテゴリー: 備忘録, 更新情報 | 投稿日: | 投稿者: | コメントを残す

コメントを残す

メールアドレスが公開されることはありません。

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください